Articles

Video 15: Area Types and Option, Part 2

In OSPF on April 25, 2011 by carlosfvc Tagged: , , , , , , ,

Implementing special area types and virtual Links:

————————-
Router 1
————————-

add static

ip route 172.31.0.0 255.255.255.0 null0
ip route 172.31.1.0 255.255.255.0 null0
ip route 172.31.2.0 255.255.255.0 null0
ip route 172.31.3.0 255.255.255.0 null0

– Static redistribution
router ospf 1
redistribute static subnets metric-type 1 metric 50

– Turning on passive interfaces
router ospf 1
passive-interface default
no passive-interface fa0/0

– Authentication MD5

config t
int f0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

————————-
Router 2
————————

router ospf 1
passive-interface default
no passive-interface f0/0
no passive-interface s0/0

– Authentication MD5

config t
int f0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

– Clear text

config t
interface s0/0
ip ospf authentication
ip ospf authentication-key cisco

– Totally stub configuration

config t
router ospf 1
area 23 stub no-summary

————————-
Router 3
————————-

– turn on passive-interface

– Clear text

config t
interface s0/0
ip ospf authentication
ip ospf authentication-key cisco

– Totally stub configuration

config t
router ospf 1
area 23 stub

– inital cost settings

area 23 default-cost 100

————————-
Router 4
————————-

– turn on passive-interface

– Authentication MD5

config t
int f0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

– Stub configuration

config t
router 1
area 45 stub

————————-
Router 5
————————-

– turn on passive-interface

– Stub configuration

config t
router 1
area 45 stub
————————-
Router 6
————————-

– turn on passive-interface

– Authentication MD5

config t
int f0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

– Virtual link

config t
router ospf 1
area 67 virtual-link 7.7.7.7

————————-
Router 7 (needs virtual links)
————————-

– Virtual link

config t
router ospf 1
area 67 virtual-link 6.6.6.6
————————-
Router 8
————————-

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: