Articles

Video 11: OSPF Routing – Implementing OSPF

In Uncategorized on April 20, 2011 by carlosfvc

OSPF Configuration

O IA – Inter-area routes

O E2 – External routes

Router 1 ASBR—————————–

config t

ip route 172.16.0.0 255.255.255.0 null0

ip route 172.16.1.0 255.255.255.0 null0

ip route 172.16.2.0 255.255.255.0 null0

ip route 172.16.3.0 255.255.255.0 null0

Basic configuration

router ospf 1

router-id 1.1.1.1

network 172.30.0.1 0.0.0.0 area 0

redistribute static *subnet metric 200 **metric-type 2

* ospf tries to summarize and subnet avoid

** ospf external router:

Type E1 increment the metric

Type E2 (Default) maintain its own metric and good when only on way

— Change the priority

int fa0/0

ip ospf priority 200

— Summarization

router ospf 1

summary-address 172.16.0.0 255.255.252.0

— change cost calculation

router ospf 1

auto-cost reference-bandwidth 1000

Router 2 ABR ——————————-

router ospf 1

router-id 2.2.2.2

network 172.0.2 0.0.0.0 area 0

network 172.30.10.2 0.0.0.0 area 10

–Change priority (no Db or BDR)

int fa0/0

ip ospf priority 0

verify

show ip ospf neighbor

show ip ospf database

Troubleshoot

clear ospf process

— Summarization

router ospf 1

area 10 range 10.10.0.0 255.255.252.0

— change cost calculation

router ospf 1

auto-cost reference-bandwidth 1000

Router 3 ABR ————————–

router ospf 1

router-id 3.3.3.3

network 172.30.0.3 0.0.0.0 area 0

network 172.30.20.3 0.0.0.0 area 20

–Change priority (no Db or BDR)

int fa0/0

ip ospf priority 0

— Summarization

router ospf 1

area 20 range 10.20.0.0 255.255.252.0

— change cost calculation

router ospf 1

auto-cost reference-bandwidth 1000

Router 4————————–

router ospf 1

router-id 4.4.4.4

netwrok 10.0.0.0 0.255.255.255 area 20

network 172.30.20.4 0.0.0.0 area 20

— change cost calculation

router ospf 1

auto-cost reference-bandwidth 1000

Router 5—————————

router ospf 1

router-id 5.5.5.5

network 10.10.0.0 0.0.255.255 area 10

network 172.30.10.5 0.0.0.0 area 10

— To advertise a loopback as a network instead of the /32

interface loopback1

ip ospf network point-to-point

— change cost calculation

router ospf 1

auto-cost reference-bandwidth 1000

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: